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1 Introduction

1.1 What is WinShell?

WinShell is a free multilingual integrated development environment (IDE) for LATEX and TEX.
The program includes a text editor, syntax highlighting, project management, a spell checker,
a table wizard, a BibTEX front-end, different toolbars and user configuration tools. It is not a
LATEX system; an additional LATEX package is required.

1.2 Installation

1.2.1 LaTeX package

A LATEX package is required. There are two common ones:

MiKTEX: http://www.miktex.org/

TEXLive: http://www.tug.org/texlive/

These packages can also be found at the different TEX communities:

ftp://ftp.dante.de/ Germany
ftp://ftp.tex.ac.uk/ England
ftp://ctan.tug.org/ USA

The LATEX packages are located at: /pub/tex/systems/win32/

1.2.2 PDF viewer

A PDF viewer has to be installed to view .pdf documents. There are several possibilities, e.g.
with Foxit Reader, GSViewer, Adobe Reader or Sumatra PDF:

Sumatra PDF: http://blog.kowalczyk.info/software/sumatrapdf/

Foxit Reader: http://www.foxitsoftware.com/pdf/rd_intro.php

GSView: http://www.cs.wisc.edu/~ghost/index.html

Adobe Reader: http://www.adobe.com/

Sumatra PDF supports SyncTEX which allows forward and inverse search in .pdf documents.

1.2.3 Postscript viewer

A postscript viewer is optional and not necessary if the focus is on creating .pdf documents.
To install Ghostscript and the GSViewer to view the .ps documents download from:

http://www.cs.wisc.edu/~ghost/index.html

http://www.miktex.org/
http://www.tug.org/texlive/
ftp://ftp.dante.de/
ftp://ftp.tex.ac.uk/
ftp://ctan.tug.org/ 
http://blog.kowalczyk.info/software/sumatrapdf/
http://www.foxitsoftware.com/pdf/rd_intro.php
http://www.cs.wisc.edu/~ghost/index.html
http://www.adobe.com/
http://www.cs.wisc.edu/~ghost/index.html
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1.2.4 WinShell

WinShell comes as a zip file and as a complete setup program. Only one is required!

Zip file: Extract the zip file to the folder of your choice and start
WinShell.exe

Setup program: The setup program copies all the WinShell files to a specific
folder, e.g. C:\Program Files\WinShell. Registry entries are
made for the icons and loading of the .tex, .bib and the .wsp
files.

The following files will be created in a folder (normally the user profile folder) depending on
the OS (Operating System) version you are running when WinShell starts for the first time:

WinShellMacros.bmp

WinShellUserTools.bmp

WinShell.ini

WinShell.macros

WinShellDict.txt

WinShell.bibtex fields

WinShell.bibtex types

When choosing WinShell as portable version these files will be stored in the Settings folder
(see Portable WinShell).

By default, WinShell tries to find the executable files by searching the registry. The LATEX
binary path should be added to the environment variable PATH (maybe in the autoexec.bat;
depending on the OS version). That is why WinShell should be installed in the last stage of
the complete installation procedure.

1.2.5 Spell checker

WinShell has a built-in spell checker. Only a dictionary has to be installed. Dictionaries are
available for free at http://wiki.services.openoffice.org/wiki/Dictionaries.

The dictionary has to be copied to the Dictionaries folder in the WinShell binary folder,
e.g. C:\Program Files\WinShell\Dictionaries.

1.3 What is new compared to WinShell 3.30?

Some of the fixes and improvements to version 3.30 are:

• Update to Scintilla 2.03

• Improved BibTeX Project Window: toggle author/label view, show all entries

• New feature: Autocompletion for LaTeX commands and BibTeX labels

• New feature: Update checker

• New feature: Split/join paragraph

http://wiki.services.openoffice.org/wiki/Dictionaries
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• New option: Reload open files at startup

• New option: BibTeX front-end: disable/enable

1.4 Features

Some of the features are: Multi language support (Brazilian-Portuguese, Catalan, Chinese,
Czech, Danish, Dutch, English, French, Galician, German, Hungarian, Italian, Mexican-
Spanish, Polish, Portuguese, Russian, Spanish, Swedish and Turkish); Project environ-
ment (Table of Contents, Figures, Tables, Bibliography); Built-in spell checker; BibTEX front-
end; Forward and inverse search; Table wizard; One-instance-program; Multiple documents;
Project and Output Window; User defined programs; Macros; Configure toolbars (symbols,
user-def. programs, macros); Choose font; Windows/Unix file format; WinShell starts com-
mand line driven; Syntax highlighting; Wrap mode; Unicode support; Drag & drop; Portable
WinShell.

1.5 What are the costs of WinShell?

This software is supplied in a binary format (’as is’) for free - the source code is not available.
In the TEX catalog it will fall under the category of ’nosource’.

There are many expenses I incur in maintaining the WinShell project that may not be ap-
parent, such as web hosting costs and the costs of new operating systems and software I
have purchased especially for writing and testing WinShell. If you desire, you may send me
donations of any amount or kind towards my efforts for keeping the WinShell project alive.

Although donations received are very much appreciated, those that do make donations do
not automatically receive preferential treatment over those who don’t.

Please contact me for further details.

1.6 Getting started...

The user may start right away if the LATEX package is correctly installed on the system (see
Installation).

The different control bars (see View) are hidden at the top of the main window right below
the toolbar. They can be moved around, formed, shown or hidden. This condition will be
saved when regularly leaving the program and be restored at the next program start.

The exe and command line can be set in the Program Calls menu.

A demo project is included in the WinShell package which will be loaded at first start. The
demo is stored in the folder Demo. Open the demo project. Click on the LATEX button of
the toolbar. Take a look at the demo project with the DVIView or PDFView application or
generate a .pdf or .ps document. If you get any error message, the LATEX package could be
installed incorrectly.





2 Menus

2.1 File

New

WinShell creates a new TEX or BibTEX document. A new BibTEX document is automatically
shown in the BibTEX front-end.

Keys: Ctrl + N (for TEX documents only)

Open

This command opens one or more existing documents either in the text editor or in the
BibTEX front-end.

Keys: Ctrl + O

File-Types
WinShell - Files (*.wsp, *.tex , *.bib, *.log) Project - Files (*.wsp)
TEX - Files (*.tex) BibTEX - Files (*.bib)
Log - Files (*.log) All Files (*.*)

Close

The active document is closed. WinShell automatically saves all changes made to the
document if chosen in the General options tab. WinShell displays the ’Save As’ dialog box,
suggests a name and saves the document when closing an untitled document.

Keys: Ctrl + W or Ctrl + F4

Save

The active document is saved to its current name and folder. WinShell displays the ’Save
As’ dialog box to name the document when a document is saved for the first time.

Keys: Ctrl + S

Save As

The active document can be renamed and saved to a new folder. WinShell displays the
’Save As’ dialog box. The Save command can be used to save a document with its existing
name and folder.
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Save All

This command names and saves all open and modified documents. When a document is
saved for the first time, WinShell displays the ’Save As’ dialog box to name the document.

Print setup

Defines the printer and page properties. The command presents a ’Print Setup’ dialog box
where different values can be set.

Print

The current .tex document is printed in the raw ASCII text format - not the .dvi or .ps docu-
ment. For a .bib document depending on the upper or lower view of the BibTEX front-end a
complete list or a single BibTEX entry will be printed.

Exit

This command exits the WinShell application. The close command on the application control
menu can be used as well. WinShell prompts to save documents with unsaved changes if
the specific check box is not activated in the General option dialog.

Keys: Alt + F4

2.2 Edit

Undo

This command will undo the last editing action if possible.

Keys: Ctrl + Z

Redo

This command will redo the previously undone action if possible.

Keys: Ctrl + Y

Cut

The Cut command removes the currently selected data from the document and copies it to
the clipboard. This command is unavailable if there is no data currently selected. Cutting
data to the clipboard replaces the contents previously stored there.

Keys: Ctrl + X
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Copy

The Copy command copies selected data to the clipboard and replaces its previously stored
contents. This command is unavailable if there is no data currently selected.

Keys: Ctrl + C

Paste

This command inserts a copy of the clipboard contents at the current cursor position. This
command is unavailable if the clipboard is empty.

Keys: Ctrl + V

Delete

This command deletes the current text selection in the active document.

Key: Del

Select All

This command selects the complete text of the active document.

Keys: Ctrl + A

Un/Comment

With this command it is possible to comment and uncomment selected text or the current
line. A ’% ’ will be added to or taken from each selected or the current line.

Keys: Ctrl + K

Split Paragraph

This command splits or reformats the current or selected paragraph(s) to a fixed text width
of 80 characters.

Keys: Ctrl + T

Join Paragraph

Keys: Ctrl + J

This command joins the current selected text lines/rows to a single paragraph.
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2.3 Search

Search

The Search command searches the active document for a given phrase. The usage of the
regular expressions is explained in table 2.1.

Keys: Ctrl + F

Find Next

The ’Find Next’ command searches the active document for the next given search expres-
sion.

Key: F3

Replace

This command replaces one expression with another in the active document. The usage of
the regular expressions is explained in table 2.1.

Keys: Ctrl + H

Search in Files

This ’Search in Files’ command searches different documents for a given phrase.

A dialog pops up to type in the search phrase, to select the documents location and the
document type. Even subdirectories can be searched. The documents location can be one
of the following: ’Current project’, ’All projects’, ’Current document’, ’All open documents’.
The type can be ’*.tex’, ’*.bib’, a combination of both or all file types.

The search result is shown in the Output Window in the ’Search Results’ tab. A double click
on a line in the ’Search Results’ tab of the Output Window jumps to the specific line in the
corresponding document.

Keys: Ctrl + Shift + F

Go to line

A small dialog pops up with an edit control to insert the line number and WinShell jumps to
that line in the current document.

Keys: Ctrl + G
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. Matches any character.
\( This marks the start of a region for tagging a match.
\) This marks the end of a tagged region.
\n Where n is 1 through 9 refers to the first through ninth tagged region

when replacing. For example, if the search string was
Fred\([1-9]\)XXX and the replace string was Sam\1YYY, when
applied to Fred2XXX this would generate Sam2YYY.

\x This allows you to use a character x that would otherwise have a
special meaning. For example, \[ would be interpreted as [ and not
as the start of a character set.

[...] This indicates a set of characters, for example, [abc] means any of
the characters a, b or c. You can also use ranges, for example [a-z]
for any lower case character.

[∧...] The complement of the characters in the set. For example, [∧A-Za-z]
means any character except an alphabetic character.

∧ This matches the start of a line (unless used inside a set, see
above).

$ This matches the end of a line.
* This matches 0 or more times. For example, Sa*m matches Sm,

Sam, Saam, Saaam and so on.
+ This matches 1 or more times. For example, Sa+m matches Sam,

Saam, Saaam and so on.

Table 2.1: Regular expressions for the search and the replace dialog. Please refer to the
Scintilla (http://www.scintilla.org/) documentation for more information.

http://www.scintilla.org/
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2.4 Execute

LATEX

LATEX compiles the Main-TEX-Document as displayed in the status bar. The command line is
set in the Program Calls menu (usually �”%s.tex”� for the cmd-line). The DOS check box
indicates that this is a DOS (Console) application and that the output is redirected to the
WinShell Output Window.

Key: F5

BibTEX

This command runs BibTEX. The command line is set in the Program Calls menu (usu-
ally �”%s”� for the cmd-line). The DOS check box indicates that this is a DOS (Console)
application and that the output is redirected to the WinShell Output Window.

There are two more options recommended: ’LATEX first’ and ’PDFLATEX first’. If a document
is modified, not compiled with LATEX or PDFLATEX, BibTEX will use the old LATEX output. Both
options are marked to avoid this: When modifying a document and pressing the BibTEX
button, LATEX or PDFLATEX will run first.

Key: F6

DVIView

The DVIView command is used to view the .dvi document of the Main-TEX-Document. The
command line is set in the Program Calls menu (usually �”%s.dvi”� for the cmd-line).

There is one more option recommended: ’LATEX first’. If a document is modified and not
compiled with LATEX, DVIView will show the old version of the .dvi document. This option is
marked to avoid that: When modifying a document and pressing the DVIView button, LATEX
is executed first.

Key: F7

Forward and inverse search

The forward and inverse search allows to jump from WinShell directly into the corresponding
position of the .dvi document and vice versa. WinShell provides the following wild cards to
use this functionality in WinShell and in the DVIViewer:

%l the current line
%s the main document
%c the current document

A double click with the left mouse button in the text in the DVIViewer or a click on the
DVIView button in WinShell accomplishes this search functionality. Only one instance of
the DVIViewer is running.
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YAP To use forward and inverse search with YAP the following changes in WinShell and
YAP have to be carried out:

WinShell Options⇒ Program Calls⇒ LATEX
cmd-line: -src-specials "%s.tex"

WinShell Options⇒ Program Calls⇒ DVIView
exe-file: yap.exe

cmd-line: -1 -s %l"%c.tex" "%s.dvi"

YAP View⇒ Options⇒ Inverse DVI Search⇒ New
Name: WinShell

Program (e.g.): "C:\Program Files\WinShell\WinShell.exe"
Arguments: -c "%f" -l %l

Table 2.2: Forward and inverse search for YAP.

dviout To use forward and inverse search with dviout the following changes in WinShell
and dviout have to be carried out:

WinShell Options⇒ Program Calls⇒ LATEX
cmd-line: -src-specials "%s.tex"

WinShell Options⇒ Program Calls⇒ DVIView
exe-file: dviout.exe

cmd-line: -1 %s.dvi "# %l "%c.tex""

dviout Option⇒ Setup Parameters⇒ Common
src (e.g.): C:\Program Files\WinShell\WinShell.exe∧s -c "%s" -l %d

Table 2.3: Forward and inverse search for dviout.

DVIPS

DVIPS creates the Postscript (.ps) document of the Main-TEX-Document from the .dvi doc-
ument. The command line is set in the Program Calls menu (usually �”%s.dvi”� for the
cmd-line). The DOS check box indicates that this is a DOS (Console) application and that
the output is redirected to the WinShell Output Window.

There is one more option recommended: ’LATEX first’. DVIPS will convert the old version
of the .dvi document if a document is modified and not compiled with LATEX. This option is
marked to avoid that: When modifying a document and pressing the DVIPS button, LATEX is
executed first.

Using �”-D600 %s.dvi”� will cause a 600dpi output document.

Key: F8
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GSView

GSView shows the Postscript (.ps) document of the compiled Main-TEX-Document. The
command line is set in the Program Calls menu (usually �”%s.ps”� for the cmd-line).

There are two more options recommended: ’LATEX first’ and ’DVIPS first’. GSView will show
the old version of the Postscript document if a document is modified, not compiled with LATEX
and DVIPS not executed. Both options are marked to avoid this: When modifying a document
and pressing the GSView button, LATEX and DVIPS will run first.

Key: F9

PDFLATEX

PDFLATEX compiles the Main-TEX-Document as displayed in the status bar into a .pdf doc-
ument. The command line is set in the Program Calls menu (usually �”%s.tex”� for the
cmd-line). The DOS check box indicates that this is a DOS (Console) application and that
the output is redirected to the WinShell Output Window.

PDFLATEX closes the working document in Adobe Reader when Adobe Reader is the pre-
ferred viewer because Adobe Reader locks the document.

Key: F10

PDFView

The PDFView command is used to view the .pdf document of the Main-TEX-Document. The
command line is set in the Program Calls menu (usually �”%s.pdf”� for the cmd-line).

A modified document will be compiled first before running the PDFView program if the check
box ’PDFLATEX first’ is enabled.

Key: F11

Forward and inverse search

The forward and inverse search allows to jump from WinShell directly into the corresponding
position of the .pdf document and vice versa. A double click with the left mouse button in
the text in the PDFViewer or a click on the PDFView button in WinShell accomplishes this
search functionality. Only one instance of the PDFViewer is running.

Sumatra PDF To use forward and inverse search with Sumatra PDF the following changes
in WinShell have to be carried out:
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WinShell Options⇒ Program Calls⇒ PDFLATEX
cmd-line: -synctex=-1 "%s.tex"

WinShell Options⇒ Program Calls⇒ PDFView
exe-file: sumatrapdf.exe

cmd-line: -reuse-instance -inverse-search

"\"C:\Program Files\WinShell\WinShell.exe\"
-c %f -l %l" "%s.pdf"

Table 2.4: Forward and inverse search for Sumatra PDF.

Spell checker

This command is used to spell check the active document via a dialog. The spell checker is
based on Hunspell (http://hunspell.sourceforge.net/).

Only a dictionary has to be installed (see Install spell checker). The usage is described in
the Use the spell checker section.

Key: F12

Table wizard

In three steps, the user will be asked for some information about the desired table layout.
Afterwards, the table will be inserted into the text at the current cursor position. See also
Use table wizard.

2.5 Options

General

The General tab in the Options dialog lets the user set the language, the file format and a
few other options.

If the first check box is activated, a backup file (.bak file) is made from a document when it is
saved to store the old version. The second check box indicates that the modified documents
are saved when exiting WinShell. If it is not marked the user will be asked if he wants the
documents to be saved or not. If the third check box is activated WinShell automatically
jumps to the error line (see Jump to error lines). If the fourth check box is activated WinShell
uses the built-in BibTEX front-end (see Use the BibTeX front-end). If the last check box is
activated WinShell will reload the open documents on the next application start.

It is also possible to choose the file format for the documents. It is either windows format
(line ending \r\n) or unix format (line ending \n).

http://hunspell.sourceforge.net/
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Language

User interface Changes the language of the WinShell user interface. Available trans-
lations for WinShell are: Brazilian-Portuguese, Catalan, Chinese, Czech, Danish, Dutch,
English, French, Galician, German, Hungarian, Italian, Japanese, Mexican-Spanish, Polish,
Portuguese, Russian, Spanish, Swedish and Turkish.

Follow these steps to translate the WinShell GUI to another language:

1. Go to the Translations folder.

2. Copy the file en US.txt to your language code, like xx yy.txt.

3. Open the file xx yy.txt in an editor and translate the English words on the right side.

4. Open the file translations.txt and add the line xx yy : Language.

5. Start WinShell to check if everything works fine.

If there are problems in displaying the correct letters in the WinShell GUI please make sure
that you have the correct language settings for your system. Choose the correct language in
the ’Regional and Language Options’ dialog:

Windows XP Start ⇒ Settings ⇒ System Control ⇒ Regional and Language Options ⇒
Advanced⇒ Language Choice for Non-Unicode Programs.

Windows Vista / 7 Start⇒ Control Panel⇒ Clock, Language and Region⇒ Regional and
Language Options ⇒ Administrative ⇒ Language for non-Unicode programs ⇒ Change
system locale...

Spell checker Also, the language of the spell checker can be set here. The available
languages depend on the installed dictionaries (see Use the spell checker).

Program calls and user programs

Use this command to set the command line for the different programs like LATEX, BibTEX etc.
It is important to add the suffix for the different program types.

The parameters %¡p¿[s, p, c]¡.xxx, .%ex¿ have the following meaning:
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%s use the document as specified in the status bar
%ps use the document as specified in the status bar with full pathname
%pp use the project pathname
%c use the current document
%pc use the current document with full pathname
xxx an extension for the document, like �tex�, �bib�, etc.
%ex the extension of the current document
%l the current cursor line of the current document; ’0’ if no line is given

The DOS check box indicates that this is a DOS (Console) application and that the output is
redirected to the WinShell Output Window.

Example for a user program To add a makeindex program to WinShell, just type in the
name section �MakeIndex� and for the exe-file �makeindex�. In the cmd-line it could be
�-o ”%s.ind” ”%s.idx”�. For more information about makeindex see the makeindex docu-
mentation. Do not mark ’LATEX first’, ’PDFLATEX first’ and ’DVIPS first’. Mark ’DOS’ to redirect
the output to the WinShell Output Window.

The next step: Go to the View menu and place the button in the toolbar (see Insert a user
tool).

Macros

Defines the macros. All in all there are ten macros. By pressing the keyboard or the button on
the macros bar, the specific macro will be inserted in the text at the current cursor position.
Different tags are provided inside a macro for special features after the macro was inserted
into the text:

¡cur¿ Sets the cursor position to that specific position.
¡sel¿ Replaces a selected text at that specific position.

The next step: Go to the View menu and place the button on the macros bar (see also the
section Insert a macro).

Keys: Shift + F1..F10

Fonts

A font can be selected for the documents, the Project Window and the Output Window. The
different encodings for the documents are listed in the following table:
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Standard Windows standard encoding
UTF-8 UTF-8 stands for the one-byte universal transformation format

to represent universal characters in the Unicode standard
ShiftJIS Japanese Shift-JIS
GB2312 Simplified Chinese GBK
Big5 Traditional Chinese Big5
Johab Korean Johab
Hangul Korean Unified Hangul Code

Table 2.5: Encoding table. Hint: Do not forget to set the correct script for the chosen font.

Syntax highlighting

Select or de-select the syntax highlighting and choose colors for commands, environments
(begin...end), braces, comment, math mode, normal text, selected text, cursor, background
and the squiggly line of the spell checker.

It is also possible to choose for matching braces. If the check box is marked, the matching
braces will appear in bold style in addition to the color set above.

Wrap mode

Toggles the word wrap mode. A check mark appears next to the menu item when the wrap
mode is enabled.

Line numbers

Toggles the line numbers. A margin to the left of the text displays the line numbers. A check
mark appears next to the menu item when the line numbers are shown.

Folding

Toggles the folding. A margin to the left of the text displays the folding plus and minus boxes.
By clicking the minus/plus boxes text blocks can be hidden and revealed to give a structured
overview of the document. A check mark appears next to the menu item when the folding
boxes are shown.

Automatic spell check

Toggles the automatic spell checking of all documents. This command enables or disables
the built-in spell checking for all documents which is based on Hunspell.

Only a dictionary has to be installed (see Install spell checker). The usage is described in
the Use the spell checker section.
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View

Customize

There are four categories to customize the toolbar and the macros bar. The first two cate-
gories handle the standard and LATEX buttons. The third category is for the user programs
and the fourth for the macros. The customization is simply to select a category, than click a
button to see its description and to drag it onto the toolbar.

Another dialog will pop up to customize the button appearance when the user program icon
is dropped on the toolbar or the macros icon on the macros bar (see Insert a user tool).

Click the icon and move it away from the toolbar (drag & drop) or use the menu item ’Delete’
from the icon’s context menu to delete the icon from the toolbar.

Project Window

Displays or hides the Project Window. A check mark appears next to the menu item when
the Project Window is displayed.

The Project Window shows information about the loaded projects. For further details look at
the Project Management section.

Output Window

Displays or hides the Output Window. A check mark appears next to the menu item when
the Output Window is displayed.

The Output Window shows the LATEX result and information generated by the different pro-
grams (see Jump to error lines), a complete .log document representation, the result of a
Search in Files and the tasks of the project (see Use tasks). The different tab windows can
not be edited, but the text can be copied via the context menu.

A double click on a line in any of the tab windows jumps to the specific line in the correspond-
ing document. You can jump directly to errors, warnings, tasks and search results in a single
document.

The tabs of the Output Window can be toggled via the right mouse:
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Toolbar

Displays or hides the toolbar. A check mark appears next to the menu item when the toolbar
is displayed.

The toolbar is displayed across the top of the application window, below the menu bar and
provides quick mouse access to many tools used in WinShell.

Status bar

Displays or hides the status bar. A check mark appears next to the menu item when the
status bar is displayed.

The status bar is displayed at the bottom of the WinShell window. The left area of the status
bar describes the action to be executed by the selected menu item or pressed toolbar button.
The right area of the status bar shows the current line and column number of the cursor and
the active Main-TEX-Document.

Other bars

Displays or hides the different bars. A check mark appears next to the menu item when the
specific bar is displayed. These bars represent some of the most common commands used
in LATEX: arrow bar, binary operator bar, accent bar, relation bar, Greek letter bar, misc bar,
macros bar (see Manage the toolbars).

2.6 Project

New

A new project is created in WinShell. A dialog pops up to name the new project. The Project
Window shows the new project as active project. Afterwards, the Main-TEX-Document, addi-
tional TEX-Documents [optional] and BibTEX-Documents [optional] have to be set (see Add
to Project).
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Open

This command opens an existing project. The right area of the status bar shows the name
of the Main-TEX-Document. The Project Window shows the

• Files

• Table of Contents (if available)

• Figures (if available)

• Tables (if available)

• Bibliography (if available)

The usage of the a project is described in detail in the ’Manage a Project’ section.

Close

The active project is closed. WinShell automatically saves all changes made to the doc-
uments if chosen in the General options tab. WinShell displays the ’Save As’ dialog box,
suggests a name and saves the document before closing an untitled document.

Save

The active project is saved to its current name and folder. WinShell displays the ’Save As’
dialog box to name the document when a document is saved for the first time.

WinShell uses relative pathnames in the .wsp documents.

Save As

The active project can be renamed and saved to a new name. WinShell displays the ’Save
As’ dialog box.

Add

The documents that belong to the project have to be added here or via the Project Window.
The Main-TEX-Document is not analyzed. The user has to handle the adding or deleting of
the project documents. Deleting a document can be achieved with the context menu of this
document in the Project Window.

Main-TEX-Document This command adds the Main-TEX-Document to the active project or
replaces the old one. The name will appear in the Project Window in bold text.

TEX-Document This command adds one or more TEX-Documents to the active project. It
will appear in the Project Window.
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BibTEX-Document This command adds one or more BibTEX-Documents to the active
project. It will appear in the Project Window.

2.7 Window

Split

Splits the active window into two panes. A dividing rule appears at the top of the window
which can be moved up and down with the left mouse button. A double click on the dividing
rule reverses the split.

Tile vertical

This command arranges the windows as non-overlapping tiles in the vertical direction.

Tile horizontal

This command arranges the windows as non-overlapping tiles in the horizontal direction.

2.8 Help

Help topics

This WinShell help is displayed.

LaTeX2e help

An English LATEX2e help is shown. The full LATEX2e help package can be downloaded from
the WinShell homepage for free. Its main components are:

LATEX2e, LATEX2e for authors, advanced LATEX, LATEX maths and graphics, LATEX, AMS-LATEX,
LATEX2e for class and package writers, LATEX2e font selection, configuration options for LATEX2e,
modifying LATEX, TEX Frequently Asked Questions, BibTEX, Makeindex and the TEX Catalog.

Check for Updates

A dialog shows up to check for new beta and/or release versions of WinShell. If a newer
version to the local version is found, WinShell downloads this file when the specific ’Update’
button is clicked. Afterwards, WinShell needs a restart to finish the update.

If the check mark ’Automatically check for updates’ is ticked, WinShell checks once a week
on new updates when WinShell starts.
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Info

This command displays the program information, version number and a copyright notice
about WinShell in a small dialog.





3 How to...

3.1 Use the command line arguments

WinShell provides the following command line arguments, used for e.g. Forward and inverse
search:

• -p project file

• -c current tex file [-l current line]

• project file

• current tex file

E.g., the command line to open a document called winshell.tex at line position 23 would
be: C:\Program Files\WinShell\WinShell.exe -c winshell.tex -l 23

3.2 Use the table wizard

Step 1 Start the table wizard from the menu Execute ⇒ Table Wizard. A dialog pops up
where the user can set values for the columns and rows.

Step 2 The next dialog shows the table with the entries which are editable.

It is possible to change the appearance of the table by clicking the small gadgets. The mouse
design changes when the mouse cursor is moved over the different gadgets.

centered text no vertical/horizontal line
right-aligned text vertical/horizontal line
left-aligned text double vertical/horizontal line
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Step 3 The user can specify a small and a long caption as well as some text for the table
which will appear in the text at the current cursor position after clicking ’OK’.

3.3 Insert a user tool

3.3.1 Create a user tool

Step 1 Go to the menu Options ⇒ User Programs. Click on the ’Tool 1’ entry in the right
list.

Step 2 Make the entries for the wanted program and press ’OK’. In this example, makeindex
will be used:

Name: MakeIndex LaTeX first: no
exe-File: makeindex PDFLaTeX first: no
cmd-Line: -o ”%s.ind” ”%s.idx” DVIPS first: no

DOS yes

For more information about makeindex see the makeindex documentation.
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3.3.2 Insert a user tool into the toolbar

Step 1 Go to the menu Options ⇒ View ⇒ Customize. Choose the category: ’User-
Programs’.

Step 2 Drag & drop the wanted tool on the toolbar. In this example, drag ’MakeIndex’ on
the toolbar.

Step 3 A dialog pops up which shows different possibilities to choose the corresponding
button. ’Tool 1’ is highlighted. In this example, press the ’Edit’ button.
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Step 4 The edit dialog pops up. Here it is possible to change the appearance of the button.
Just press the ’OK’ button when finished.

Step 5 The modified button appears in the image list. Again, press the ’OK’ button. The
button now appears in the toolbar.
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Step 6 Move the mouse pointer to the ’Spell Checker’ button and press the right mouse
button for the context menu to insert a separator; choose the ’Group’ button.

Step 7 Finish the insertion by pressing the ’Close’ button on the dialog. The modified
toolbar should look like this:

Hint: How to delete an icon from the toolbar? Open the customization dialog (see Step 1).
Either left click the desired icon with the mouse and move it away from the toolbar (drag &
drop) or use the menu item ’Delete’ from the icon’s context menu.



28 How to...

3.4 Insert a macro

3.4.1 Create a macro

Step 1 Go to the menu Options ⇒ Macros and choose the number of the macro from the
drop down list (F01..F10).

Step 2 Make your entries for the wanted macro. Different tags are provided inside a macro
for special features after the macro was inserted into the text:

¡cur¿ Sets the cursor position to that specific position.
¡sel¿ Replaces a selected text at that specific position.
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3.4.2 Insert a macro into the toolbar

Step 1 Go to the menu Options ⇒ View ⇒ Customize. Choose the category: ’User-
Macros’.

Step 2 Move the mouse pointer to ’Macro 1’ and press the right mouse button. The context
menu allows the user to modify the appearance of the button. Click the ’Edit’ entry.

Step 3 The edit dialog pops up. Here it is possible to change the appearance of the button.
Just press the ’OK’ button when finished.

The next steps proceed like in the previous section.
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3.5 Manage the toolbars

This is how it looks when all toolbars are shown. It is possible to move and form each toolbar.
These positions are stored when exiting WinShell and reloaded at the next start.

Step 1 This example shows the accent bar. Drag the gripper of the accent bar to any place.
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Step 2 It is possible to manipulate the accent bar and move the bar to its destination place
by dragging at the edges. This position will be reloaded at the next start of WinShell.
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3.6 Manage a project

The usage of the Project Window allows to manage the documents and the information about
a project. A project document contains relative pathnames. A demo project is included in the
WinShell package which will be loaded at first start. The demo is stored in the folder Demo.
Open the demo project. Click on the LATEX button of the toolbar. Take a look at the demo
project with the DVIView or PDFView application or generate a .pdf or .ps document. If you
get any error message, the LATEX package could be installed incorrectly.

The project which will be compiled is marked bold in the Project Window. If you want to
compile a different project (like the ”Current document”), you need to activate the project
with the ”Activate” command in the context menu.

3.6.1 Left Mouse Button

A double click on an item of the project has the following effects:

Documents A .tex document will open at line 1 or simply shown if it is already opened. A
.bib document will open w

Table of Contents The document will open at that specific line position. The ’Table of
Contents’ contains: \chapter \section \subsection \subsubsection.
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Figures The document will open at the line of the figure. The document name and the line
of the figure is shown in the entry if the figure has no label. WinShell only takes the figure

environment into account.

Tables The document will open at the line of the table. The document name and the line
of the table is shown in the entry if the table has no label. WinShell only takes the table

environment into account.
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Bibliography

• Bibliography label: Opens the BibTEX document in the BibTEX front-end at the position
of the BibTEX entry.

• Subtree of the bibliography label: Opens the .tex document at the given line. This is
where the BibTEX entry is cited.
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3.6.2 Right Mouse Button

A context menu pops up after a right mouse click depending on the tree entry the mouse
focuses.

Activate Activates this project.

Reload Reloads the information of the project.

Sort The documents, figures and tables can be alphabetically sorted. When disabled, the
documents appear in the order in which they have been included into the project.

Tooltips The tooltip for the project entry shows the working path and for the document
entries it shows the complete path.

References and citations References to figures and tables and citations of BibTEX entries
can be inserted directly into the current cursor position in the text.

Sort by Author The Project Window sorts the shown BibTEX entries by BibTEX author field,
if this check mark is set. Otherwise the sorting is by BibTEX label field.

Show All The Project Window shows all BibTEX entries, if this check mark is set.
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3.7 Jump to error and warning lines

A double click on a LATEX error or warning line in the Output tab of the Output Window jumps
to the specific line in the corresponding document. An error line is drawn in red.

Additionally, WinShell jumps automatically to the first error line when the check mark in the
General tab in the Options dialog is set.

Hint: Adding the nonstopmode command to the LATEX program call prevents the LATEX run to
stop at errors and makes a compilation of the complete project or document:

• Options⇒ Program Calls⇒ LATEX
cmd-line: -interaction=nonstopmode "%s.tex"
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3.8 Use tasks

A double click on a line in the Tasks tab of the Output Window jumps to the specific line in
the corresponding document. Tasks are marked with a ’% todo:’ tag in the text.

This feature provides some kind of reminder functionality. It can be used within a document
or project where the user needs to add e.g. some additional information later.
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3.9 Use the spell checker

3.9.1 Automatic spell check

WinShell has a built-in spell checker. Only a dictionary needs to be downloaded. Dictionar-
ies are available for free at http://wiki.services.openoffice.org/wiki/Dictionaries.
Any version on that website will work. It is recommended to use the latest released version.
The dictionary has to be copied to the Dictionaries folder in the WinShell binary folder.

E.g., download the American English dictionary en US.zip from the homepage above. Unzip
its contained files en US.aff, en US.dic and README en US.txt to the Dictionaries folder
of the WinShell binary folder, e.g. C:\Program Files\WinShell\Dictionaries.

The spell checker icon in the Options menu enables or disables the automatic spell checking.
Unknown words are squiggly underlined. The color of the squiggly line can be set in the
Syntax highlighting menu. Different features how to handle the unknown word are provided
via the context menu (right mouse button click over an unknown word).

The first bold entries in the context menu are suggestions to replace the unknown word.
Choosing one of them replaces the unknown word in the text. Other options are to ignore the
unknown word in the text or even store it in the personal dictionary for future spell checking.

It is possible to choose the spell checking language from the context menu and edit the
personal dictionary. Also, the spell check dialog can be started from the context menu.

http://wiki.services.openoffice.org/wiki/Dictionaries


3.10 Use portable WinShell 39

3.9.2 Spell check dialog

The dialog spell check button in the ’Execute’ menu and in the toolbar is enabled when a
document is loaded. The checking starts from the current mouse position. A dialog pops
up to show the unknown word which is also highlighted in the document. A suggestion list
is displayed. At the bottom of the dialog the language of the dictionary can be chosen (left
image).

A personal dictionary can be created if the word is not in the given suggestion list. The
word can be added and the personal dictionary be edited (right image). It is saved in the
WinShellDict.txt file which is stored in a folder (normally the user profile folder) depending
on the OS (Operating System) version you are running or in the ’Settings’ folder when in
portable mode.

3.10 Use portable WinShell

A folder named Settings has to be created in the WinShell binary folder to use WinShell
as a portable version. E.g., if F: is your flash disk, follow these steps:

1. Unzip the WinShell zip file to F:

2. Create the folder F:\WinShell\Settings

After a restart of WinShell the application archives all information in the Settings folder
from that time on. To disable the portable mode again the complete Settings folder has to
be removed.
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3.11 Use the BibTeX front-end

3.11.1 General overview

A .bib document it is automatically shown in the BibTEX front-end if the check mark in the
General options tab is checked

In the upper view one can find an overview list of all the BibTEX entries. By clicking with the
mouse on the header the list can be sorted. A triangle indicates an ascending or descending
order. Clicking a single line shows the detailed information of the BibTEX entry in the lower
view. There is the type and label information followed by the required and the optional fields.
Each type has a set of required and optional fields.

For faster navigation in the lower view, one can use the TAB key to navigate to the different
fields. If the field to change has been reached, a hit on the RETURN key will change into
edit mode of this field.

It is possible to switch between the text view and the editor view via the context menu of the
tab of the document:
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Hint: For a .bib document depending on the upper or lower view of the BibTEX front-end a
complete list or a single BibTEX entry will be printed.

3.11.2 The context menu

Via the context menu of the upper or lower view the .bib document as well as the BibTEX
types, fields, strings, preamble can be changed.

The copy mechanism works from valid BibTEX format text input, also the paste mechanism
copies a BibTEX entry in BibTEX format to the clipboard.

3.11.3 A new BibTeX entry

Via the context menu or via the keyboard shortcut CTRL + I a new BibTEX entry is created of
the type article with unknown author, unknown journal, unknown title, the current year
and a random label.



42 How to...

3.11.4 Edit a BibTeX entry

A BibTEX entry can be edited in the lower view where the detailed information is displayed.
The edit box on the right of each field can be activated by a mouse click and then be edited.

3.11.5 Edit the preamble

To edit the preamble of the .bib document, choose accordingly in the context menu. A dialog
pops up and the preamble can be typed in.

3.11.6 Edit the strings

To edit the strings of the .bib document, choose accordingly in the context menu. A dialog
pops up and the strings can be modified.
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3.11.7 Edit the types and fields

To modify the types and fields, choose accordingly in the context menu. A dialog pops up
and the types and fields can be modified.

When a type is selected the required and optional fields are displayed accordingly. An in-
formation text about the currently selected type and field is shown and can be edited. Any
modification of the information text will be stored.
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New types and fields can be added via the ’Add...’ button. User types and fields can be
deleted via the ’Delete...’ button. The standard types and fields cannot be deleted. The
’Default’ button resets all the types and fields to the standard ones and all user types and
fields will be deleted.

With the ’¿’ and ’¡’ buttons it is possible to change the required and optional fields for a type.

The modifications are stored in the files:
WinShell.bibtex fields

WinShell.bibtex types

These files are located in the WinShell user profile folder.

3.12 Use the Autocompletion

Autocompletion in the text editor is initiated with a ’\’ followed by a combination of two
keystrokes, namely CTRL and SPACE, at a time. After you have typed e.g. ’\be’ followed by
CTRL+Space WinShell displays a list box showing likely identifiers. The currently selected
item can be chosen by pressing the TAB key or via the mouse.

WinShell has an extended autocompletion, meaning that not only the keyword is shown, but
also the complete environment is filled into the text editor and the cursor is positioned at a
reasonable position.

Autocompletion also works with the BibTEX entries. Type the keyword ’\cite’ and place
the cursor is in between the braces (Autocompletion will do this automatically). Another
CRTL+Space keystroke will show a list of the labels which can be inserted. The list of labels
is generated from the BibTEX file(s) which belong to the active project.

If the likely identifier list contains only a single item, this single item will be automatically
inserted without showing a selection list.



4 Bug report

4.1 Before sending a bug report

Please download the latest version from the WinShell homepage before sending any bug
report. Include the following information in your email (in English or German only!) when
sending a bug report:

My Computer:

On which Windows system do I work?

Which service pack is installed?

Which LaTeX system do I use?

WinShell:

Which version (plus upload date) of WinShell am I using?

Bug:

Description of the exact way how this error was produced!

What is the exact error message?

Is it reproducible?

Did I try it on other machines?

Did I try it on other systems?
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